Significant delay when trying to access the inbox

Incident Report for Agorapulse

Resolved

This incident has been resolved.
Posted Nov 04, 2025 - 18:49 CET

Monitoring

Inbox speed has improved after a fix was released. We are continuing to monitor the situation. Thank you for your patience
Posted Nov 04, 2025 - 17:37 CET

Investigating

We are currently investigating an issue where users are seeing a significant delay when trying to access the inbox.
Posted Nov 04, 2025 - 14:01 CET
This incident affected: Web Application (app.agorapulse.com).